[ACE-5647] [Win7,chrome] Configure dashboard - Configuration not saved after removing dashlets to trashcan Created: 05-Dec-16  Updated: 14-Mar-17  Resolved: 14-Dec-16

Status: Closed
Project: Alfresco One Platform
Component/s: Applause (Temp)
Affects Version/s: 5.2
Fix Version/s: 5.2

Type: Bug Priority: Critical
Reporter: Applause Test Integration Assignee: Closed Issues
Resolution: Fixed Votes: 0
Labels: kanban, triaged
Remaining Estimate: 0 minutes
Time Spent: 4 hours
Original Estimate: Not Specified

Attachments: JPEG File ACE-5647.JPG     File Bug2366091_config.swf     PNG File GetStartedPanelHidden.png     PNG File PassIn512NonAdminUser.png     PNG File PassIn51nNonAdminUser.png     PNG File PassIn520NonAdminUser.png     File alfresco-global.properties    
Issue Links:
Duplicate
is duplicated by ACE-5624 'Get started' panel doesn't dissapear Closed
is duplicated by ACE-5643 [Win10 - MS Edge] Home: Hide 'Get Sta... Verified
is duplicated by MNT-17609 non-admin users cannot configure thei... Closed
Related
relates to MNT-16371 Update initial permissions on surf-co... Closed
is related to by ACE-5661 External authentication Problem with CAS Closed
Build Location: https://nightlybuilds.alfresco.com/Enterprise-5.2/5.2/build-00015/

 Description   

View your issue at Applause Testing Services - https://platform.applause.com/products/12989/testcycles/123540/issues/2366091
---- ACTION DETAILS ----

Action Performed:
1. Login to the url
2. Click settings icon to configure dashboard
3. Remove some dashlets in columns by dragging them to trashcan
4. Click Ok to save configuration
5. CLick Settings icon again and observe

Expected Result:
Dashlets removed should not be displayed

Actual Result:
Dashlets removed are still displayed after going back to configuration page

Additional Info:
Issue not on 5.1.1

Error Code/Message:

---- ENVIRONMENT ----

Antivirus:McAfee,Language:English ,Operating System:Windows,Operating System Version:7 64-bit,Web Browser:Chrome,Desktop Accessories:Webcam,Desktop Accessories:Microphone,Desktop Accessories:Speakers,Desktop Accessories:Headset

2016-12-05 13:20:42.0:Thank you for confirming. The reason I asked is I could reproduce as non-admin but it worked fine as an admin.
2016-12-05 12:55:50.0:I used admin20/ApplauseV1876 credentials. Thanks
2016-12-05 11:10:32.0:Is this as an admin user or non-admin?
2016-12-04 10:37:23.0:Done. Thanks
2016-12-04 10:31:58.0:Important: You must indicate if the bug you have submitted is also on a previous version (5.1.1) of the product. You can access version 5.1.1 here:
http://ec2-54-93-94-243.eu-central-1.compute.amazonaws.com:8080/share
Login: admin1 / ApplauseV1876
Write in your bug report either: Issue also on 5.1.1 or Issue not on 5.1.1

---- UTEST PROPERTIES ----

uTest Bug Id: 2366091

Title: [Win7,chrome] Configure dashboard - Configuration not saved after removing dashlets to trashcan
Status: Approved

Type: Functional
Frequency: Every Time
Severity: High

Product: Alfresco One (52GA - Stack 1)
Test Cycle: Alfresco One - Exploratory - 52GA

---- 4 Custom Fields ----

Exact browser build version: Version 54.0.2840.99 m
Exact URL: http://oracluster52-347170320.eu-central-1.elb.amazonaws.com:8080/share/page/customise-user-dashboard
Your Country, Locale, Device Language: Nigeria, Lagos, English
Operating System Version (Including servicepack): Win7 64bit

---- UTEST Attachment ----

Bug2366091_config.swf : https://utest-dl.s3.amazonaws.com/8610/12989/123540/null/bugAttachment/Bug2366091_config.swf?AWSAccessKeyId=AKIAJVVOIXUIFRTEEEKQ&Expires=1796476961&Signature=jke1k3qyBDAQ%2BgF07oiz%2BESU1cY%3D



 Comments   
Comment by Simon Godfrey [ 05-Dec-16 ]

Raised via Applause and reproduced by Alfresco. Triaged 5-12-2016.

Comment by Kevin Roast [X] (Inactive) [ 05-Dec-16 ]

Just tried this, cannot reproduce on 5.2.0, works correctly. This feature has not changed since the testing performed at the start of 5.2 when this feature was first added.

Is this system configured to use clustering? Is a proxy being used? Is the clustering/proxy set-up correctly for Share if so? This is the most common reason dashboard configuration is not persisted - it is not a product issue.

Comment by Simon Godfrey [ 05-Dec-16 ]

Iulian Mitrea [X] Can you answer Kevin's questions above for http://172.29.100.248:8080/share please as I am able to reproduce this with non-admin users. Thanks.

Comment by Kevin Roast [X] (Inactive) [ 05-Dec-16 ]

FYI I tested with a non-admin user. Last year when testing 5.1 we have had issues before with the configuration of the test system for applause usage that produced issue like this (from memory).
Can you confirm the system License is installed correctly also, I assume it is not in read-only mode.

Comment by Iulian Mitrea [X] (Inactive) [ 05-Dec-16 ]

I tested on my side and a non-admin user cannot delete dashlets from user Dashboard
The system is not configured to use clustering. No proxy is used.
http://www.screencast.com/t/YBoqeYfUo

alfresco-global.properties

Comment by Kevin Roast [X] (Inactive) [ 06-Dec-16 ]

There is some set-up issue. I do not know what/how these builds are deployed to cloud for this testing, but there is likely some problem with that process.

I will have our testers confirm there are no product issue using a 5.2.0 build from here: https://bamboo.alfresco.com/bamboo/browse/ALF-EPACK26

Comment by Kevin Roast [X] (Inactive) [ 06-Dec-16 ]

One of our testers has (eventually) managed to reproduce the issue with a non-admin user. FYI this is the kind of information we actually need to know if this is a bug: - the repo log when it occurs:

2016-12-06 09:14:00,596  ERROR [extensions.webscripts.AbstractRuntime] [http-bio-8080-exec-141] Exception from executeScript: 11060147 Access Denied.  You do not have the appropriate permissions to perform this operation. org.alfresco.repo.security.permissions.AccessDeniedException: 11060147 Access Denied.  You do not have the appropriate permissions to perform this operation.        at org.alfresco.repo.security.permissions.impl.ExceptionTranslatorMethodInterceptor.invoke(ExceptionTranslatorMethodInterceptor.java:57)        at org.springframework.aop.framework.ReflectiveMethodInvocation.proceed(ReflectiveMethodInvocation.java:172)        at org.alfresco.repo.audit.AuditMethodInterceptor.invoke(AuditMethodInterceptor.java:166)        at org.springframework.aop.framework.ReflectiveMethodInvocation.proceed(ReflectiveMethodInvocation.java:172)        at org.alfresco.repo.transaction.RetryingTransactionInterceptor$1.execute(RetryingTransactionInterceptor.java:86)        at org.alfresco.repo.transaction.RetryingTransactionHelper.doInTransaction(RetryingTransactionHelper.java:464)        at org.alfresco.repo.transaction.RetryingTransactionInterceptor.invoke(RetryingTransactionInterceptor.java:76)        at org.springframework.aop.framework.ReflectiveMethodInvocation.proceed(ReflectiveMethodInvocation.java:172)        at org.alfresco.enterprise.repo.authorization.AuthorizationStatusInterceptor.invoke(AuthorizationStatusInterceptor.java:189)        at org.springframework.aop.framework.ReflectiveMethodInvocation.proceed(ReflectiveMethodInvocation.java:172)        at org.springframework.aop.framework.JdkDynamicAopProxy.invoke(JdkDynamicAopProxy.java:204)        at com.sun.proxy.$Proxy46.addAspect(Unknown Source)        at org.alfresco.repo.web.scripts.bean.ADMRemoteStore.deleteDocument(ADMRemoteStore.java:632)        at org.alfresco.repo.web.scripts.bean.BaseRemoteStore.execute(BaseRemoteStore.java:302)        at org.alfresco.repo.web.scripts.RepositoryContainer$3.execute(RepositoryContainer.java:512)        at org.alfresco.repo.transaction.RetryingTransactionHelper.doInTransaction(RetryingTransactionHelper.java:464)        at org.alfresco.repo.web.scripts.RepositoryContainer.transactionedExecute(RepositoryContainer.java:587)        at org.alfresco.repo.web.scripts.RepositoryContainer.transactionedExecuteAs(RepositoryContainer.java:656)        at org.alfresco.repo.web.scripts.RepositoryContainer.executeScriptInternal(RepositoryContainer.java:428)        at org.alfresco.repo.web.scripts.RepositoryContainer.executeScript(RepositoryContainer.java:308)        at org.springframework.extensions.webscripts.AbstractRuntime.executeScript(AbstractRuntime.java:399)        at org.springframework.extensions.webscripts.AbstractRuntime.executeScript(AbstractRuntime.java:210)        at org.springframework.extensions.webscripts.servlet.WebScriptServlet.service(WebScriptServlet.java:132)

I am wondering if there is new behaviour running in the delete node code i.e. some behaviour running that was not executing before.

Comment by Kevin Roast [X] (Inactive) [ 06-Dec-16 ]

That's great thanks. Can you ensure this is merged back to all affected branches.

Comment by Ramona Neamtu [ 07-Dec-16 ]

Changes committed into BRANCHES/DEV/5.2.N @revision r133350.

Merged into PATCHES/5.2.0 @revision r133416, BRANCHES/DEV/5.1.N @revision r133417 and PATCHES/5.1.2 @revision r133418.

Comment by Meenal Bhave [X] (Inactive) [ 09-Dec-16 ]

Tested in 5.2.1: admin and non admin user can hide the get started panel

Comment by Ramona Neamtu [ 13-Dec-16 ]

Full installer for 5.2.N: https://nightlybuilds.alfresco.com/Enterprise-5.2/5.2.N/build-00369/ALL/
Full installer for 5.2.0: https://bamboo.alfresco.com/bamboo/browse/ALF-EPACK26-15/artifact/JOB1/ALL/
Full installer for 5.1.N: https://bamboo.alfresco.com/bamboo/browse/ALF-EPACK7-589/artifact/JOB1/ALL/
Full installer for 5.1.2: https://bamboo.alfresco.com/bamboo/browse/HF-ENT513-17/artifact/BUIL/ALL/

Comment by Meenal Bhave [X] (Inactive) [ 14-Dec-16 ]

Tested that changes to the dashboard configurations (dashlets and the Get Started panel) are saved in 5.2.n, 5.2.0, 5.1.n, 5.1.2: works well.

Generated at Sat Jul 04 16:27:27 BST 2020 using JIRA 7.6.3#76005-sha1:8a4e38d34af948780dbf52044e7aafb13a7cae58.