[ALF-1573] Full Export succeeds w/o ealier versions being transfered Created: 14-Nov-08  Updated: 23-Aug-11  Resolved: 20-Apr-10

Status: Closed
Project: Alfresco
Component/s: Repository
Affects Version/s: 3.2 Community
Fix Version/s: None
Security Level: external (External user)

Type: Improvement Priority: Critical
Reporter: Stefan Schilling (Inactive) Assignee: Unassigned
Resolution: Duplicate Votes: 1
Labels: None
Remaining Estimate: Not Specified
Time Spent: Not Specified
Original Estimate: Not Specified
Environment:

ubuntu hardy,
alfresco@alfresco:~$ uname -r
2.6.24-21-server
alfresco@alfresco:~$ mysql --version
mysql Ver 14.12 Distrib 5.0.51a, for debian-linux-gnu (i486) using readline 5.2
alfresco@alfresco:~$ java -version
java version "1.5.0_15"
Java(TM) 2 Runtime Environment, Standard Edition (build 1.5.0_15-b04)
Java HotSpot(TM) Client VM (build 1.5.0_15-b04, mixed mode, sharing)
alfresco@alfresco:~$


Issue Links:
Duplicate
Date of First Response:

 Description   

Hello!

I'm running two Alfresco-3b Versions, install1 = Rev. 3194, install2 = Rev. 3213.

Following the instructions given at http://wiki.alfresco.com/wiki/Export_and_Import, I want to transfer some of the spaces being used in install1 to install2 inclusive all the versioning information stored w/ a document. Therefore I used the two different Export / Import - functions available (1 is using details of a space -> Export / Import, the other one tried was using the administrative console -> Export / Import).

Both ways worked (aka. all files got transfered), but no versioning information was saved (all documents have today's timestamp and only the latest version is available).

There is no Exception or error message coming up anytime during the process.

As I don't just copy the files but really export them, I consider this to be a bug. Or is there another way to export and the import a space from alfresco including ALL versioning information and all versions of a document?

Thanks for your help.

Bye,
Stefan



 Comments   
Comment by mkononovich [ 17-Jun-09 ]

Yes, the content versions (the same way as the Categories and Multilingual properties) are not saved after the export/import.
Tested in Alfresco 3.2 Labs build 1925 using Windows 2003 R2 SP2, Tomcat 6.0.18, Mysql 5.1.31, JDK 6u7 x32
Raising to the Critical level.

Comment by Jan Vonka [ 20-Apr-10 ]

Duplicate (refer to ENH-329)

Generated at Tue Aug 11 23:44:08 BST 2020 using Jira 7.13.15#713015-sha1:7c5ddd2c3e1709974ae9c48c17df8edd3919fe2c.