[MNT-11654] Manage System Users: Email domain, which contains underscore, is not valid Created: 09-Jun-14  Updated: 03-Sep-14  Resolved: 24-Jun-14

Status: Closed
Project: Service Packs and Hot Fixes
Component/s: Alfresco Explorer
Affects Version/s: 4.2.2
Fix Version/s: 4.2.3

Type: Bug
Reporter: Alfresco QA Team (Inactive) Assignee: Closed Bugs (Inactive)
Resolution: Fixed Votes: 0
Labels: None
Remaining Estimate: 0 minutes
Time Spent: 1 day, 15 minutes
Original Estimate: Not Specified
Environment:

Enterprise v4.2.2 (r70245-b51).
Suse 11.3 x64, Oracle 11g v11.2.0.3, Ojdbc6.jar (use 'jdbc:oracle:thin' in db_url), Tomcat 7.0.42, JDK 7 U25 X64.
Client: Windows 7 SP1 x64, FF v29.0.1


Attachments: PNG File screen1.png    
Bug Priority:
Category 3
Build Location: http://releases.alfresco.com/Enterprise%204.2/4.2.3/build-00050/
Regression Since:

 Description   

Steps to Reproduce:

  1. Log in to Alfresco Explorer as admin user.
  2. Open the Admin Console > Manage System Users page.
  3. Click on the Create User button.
  4. Enter any valid data into the First Name and the Last Name fields.
  5. Enter an email address with an underscore in the domain, e.g. test1@test_1.com.
  6. Click on the Next button.

Observed Result:

"Email format is not valid" message is displayed. Please, see the attached screen1.png.

Expected Result:

The email is correct. It should be processed successfully. No error should occur.

Regression:

  • The issue was not reproduced on Enterprise v4.2.1 (r63452-b50).
  • The issue seems to be a regression since MNT-8444, i.e. the error came from the released 4.2.2 (r70245-b51).

Additional Note:

  • The issue was not reproduced in Share - the email domain was processed correctly via Share Admin Console.
  • Set the higher "Major" priority because of the regression.

ChristinaSh


Generated at Sun Jan 24 16:38:47 GMT 2021 using Jira 7.13.15#713015-sha1:7c5ddd2c3e1709974ae9c48c17df8edd3919fe2c.