[MNT-12775] Problem with L10N of patch message when upgrading from unsupported revision Created: 11-Oct-14  Updated: 10-Apr-15  Resolved: 02-Feb-15

Status: Closed
Project: Service Packs and Hot Fixes
Component/s: Upgrades
Affects Version/s: 5.0
Fix Version/s: 5.0.1

Type: Bug
Reporter: Derek Hulley [X] (Inactive) Assignee: Closed Bugs
Resolution: Fixed Votes: 0
Labels: 5.0.N
Remaining Estimate: 0 minutes
Time Spent: 1 day, 1 hour
Original Estimate: Not Specified
Environment:

Any


Issue Links:
Related
Bug Priority:
Category 4
Build Location: https://releases.alfresco.com/Enterprise-5.0/5.0.1/build-00068/

 Description   

Do a direct upgrade from V3.3.0 to V5.0.
An error will, correctly, prevent upgrade:

 2014-10-11 13:26:11,414  INFO  [management.subsystems.ChildApplicationContextFactory] [main] Startup of 'Search' subsystem, ID: [Search, managed, solr] complete
 2014-10-11 13:26:11,424  INFO  [admin.patch.PatchExecuter] [main] Checking for patches to apply ...
 2014-10-11 13:26:11,704  INFO  [admin.patch.PatchExecuter] [main] 	Applying patch 'patch.redeployJbpmAdhocWorkflow' (Redeploy JBPM adhoc workflow).
 2014-10-11 13:26:11,704  ERROR [admin.patch.PatchExecuter] [main] 09110002 patch.NoLongerSupportedPatch.err.use_incremental_upgrade
 2014-10-11 13:26:11,744  ERROR [admin.patch.PatchExecuter] [main] 
=== Failed to apply patch         === 
ID: patch.redeployJbpmAdhocWorkflow
RESULT: 
09110002 patch.NoLongerSupportedPatch.err.use_incremental_upgrade
=====================================

The L10N exists in patch-service.properties but is not being used. Other, value alongside it are being picked up. It should be something like:

\nPatch ''{0}'' was last supported on version {1}.\n   Please follow an incremental upgrade using version {2}.

Note that the specific patch to issue the message is not important; just the L10N needs checking.


Generated at Tue Aug 11 22:55:21 BST 2020 using Jira 7.13.15#713015-sha1:7c5ddd2c3e1709974ae9c48c17df8edd3919fe2c.