[MNT-1776] Error displaying tool tip with quote Created: 21-Jul-09  Updated: 22-Mar-13  Resolved: 10-Mar-10

Status: Closed
Project: Service Packs and Hot Fixes
Component/s: Installer
Affects Version/s: No Version
Fix Version/s: 2.2.7

Type: Service Pack Request
Reporter: Fabrizio Corsaro [X] (Inactive) Assignee: Closed Bugs (Inactive)
Resolution: Fixed Votes: 0
Labels: None
Remaining Estimate: Not Specified
Time Spent: Not Specified
Original Estimate: Not Specified
Environment:

Alfresco 2.2


Issue Links:
Dependency
Bug Priority:
Category 2
ACT Numbers:

8997

Testcase ID:

Explorer-2524


 Description   

Our application is in french language and when we customize messages we have a problem with messages containing quote (') and displaying in tool-tip (alt attribute).
For example, french message for "Admin console" is "Console d'administration". So the tool tip display : "Consol d" because alt attribute is closed by the quote when "img" tag is generated by the taglib.

I have tried to modify message with :
Console d''administration
or
Console d\\\'administration

But it doesn't resolve our problem.



 Comments   
Comment by Fabrizio Corsaro [X] (Inactive) [ 21-Jul-09 ]

Can we back port the fix applied to 3.1 SP1 onto 2.2?

Comment by Kevin Roast [X] (Inactive) [ 21-Jul-09 ]

Yes we can backport

Comment by Helen Dann (Inactive) [ 27-Nov-09 ]

Diamond customer staying on 2.2

Comment by Kevin Roast [X] (Inactive) [ 08-Mar-10 ]

CHK-11644

Comment by Steve Rigby [X] (Inactive) [ 09-Mar-10 ]

for retest in 2.2 sp7

Comment by Alfresco QA Team (Inactive) [ 10-Mar-10 ]

Successfully validated using Alfresco 2.2 SP7 b531 Windows 2003 R2 x64, JBoss 4.2.3, Oracle 10g x64, JDK 6u16, NTLM passthru, Windows Vista SP1, FF 3.5 and using RHEL 5, Tomcat 6.0.18, MySQL 5.1.40, JDK 5u16, Kerberos, Windows XP, IE 7

Generated at Tue May 18 06:45:25 BST 2021 using Jira 7.13.15#713015-sha1:7c5ddd2c3e1709974ae9c48c17df8edd3919fe2c.