[MNT-18629] APS: Publish to Alfresco task fails with image mimetypes Created: 22-Aug-16  Updated: 03-Aug-20  Resolved: 03-Aug-20

Status: Closed
Project: Service Packs and Hot Fixes
Component/s: APS Kickstart/Studio
Affects Version/s: Alfresco Process Services 1.6.1, Alfresco Process Services 1.6.4.2, Alfresco Activiti 1.5.1
Fix Version/s: None

Type: Bug
Reporter: Luke Creswick [X] (Inactive) Assignee: Closed Issues
Resolution: Won't Fix Votes: 6
Labels: Content-Storage, London
Remaining Estimate: Not Specified
Time Spent: Not Specified
Original Estimate: Not Specified
Environment:

Alfresco 1.5, Activiti 1.5, MMM 1.0.2-4, CentOS, Virtualbox


Attachments: Zip Archive Test upload.zip     Text File activiti catalina publish to alfreco error.txt     Text File publishtoalfrescoerror.log    
Issue Links:
Shadow
Bug Priority:
Category 1
Sprint: Docs Sprint 18

 Description   

create a basic process with a simple start form. start form has one "attach" field, to allow the user to upload a document. then add a "Publish to Alfresco" task, and configure it:

  • to upload the document from the "attach field"
  • upload to a folder in Alfresco as process initiator

the document is created in Alfresco, but the task does not complete, hence workflow doesn't progress. Error includes:

  • error while creating or updating document
  • org.apache.chemistry.opencmis.commons.exceptions.CmisInvalidArgumentException: Extensions tree too wide!

full Activiti catalina.log attached



 Comments   
Comment by Paul Holmes-Higgin [X] (Inactive) [ 22-Aug-16 ]

Any details on which version of Alfresco One is in that powerbundle?

Thanks
Paul.

Comment by Luke Creswick [X] (Inactive) [ 22-Aug-16 ]

Alfresco One 5.1.1

Comment by Paul Holmes-Higgin [X] (Inactive) [ 22-Aug-16 ]

Thanks. And is this using the Share Connector?

Comment by Luke Creswick [X] (Inactive) [ 22-Aug-16 ]

Yes Share Connector installed.

Comment by Paul Holmes-Higgin [X] (Inactive) [ 22-Aug-16 ]

Any metadata published at the same time? Or just the content?

Comment by Luke Creswick [X] (Inactive) [ 22-Aug-16 ]

Basic test I setup was just content

Comment by Paul Holmes-Higgin [X] (Inactive) [ 22-Aug-16 ]

Thanks. I've tried publishing without the Share Connector and it's worked fine, so I'll try with the Share Connector next.

Comment by Paul Holmes-Higgin [X] (Inactive) [ 22-Aug-16 ]

I can't reproduce this. I'm working with AlfOne 5.1.1 and Activiti EA5.

Comment by Luke Creswick [X] (Inactive) [ 22-Aug-16 ]

Hmm thanks PHH must be something odd in our powerbundle setup, I will work with JT Smith further to see if we can figure it out, cheers

Comment by Luke Creswick [X] (Inactive) [ 23-Aug-16 ]

looks like the issue is just to do with "Publish to Alfresco" task publishing images. Suspect it is an issue with the many additional properties set on an image for the EXIF and IPTC aspects. We have Media Management (hence IPTC aspect) in Powerbundle, so not sure if same issue occurs without MM installed.

Comment by Paul Holmes-Higgin [X] (Inactive) [ 23-Aug-16 ]

That makes sense - the CMIS issue is to do with that. We'll have to see what needs to be done to avoid it in a future release.

Comment by John-Taylor Smith [X] (Inactive) [ 14-Sep-16 ]

I was able to reproduce the error with the simple app I'll attach.

I ran it in two environments, one with Media Management Module and one without. Images failed to publish to Alfresco with the MMM installed. The successfully published into the environment without it.

My Env was:

Alf 5.1.1
Act 1.5 (with corresponding share connector)
MMM 1.0.2-4

Comment by John-Taylor Smith [X] (Inactive) [ 14-Sep-16 ]

Attaching the Activiti log

Comment by Trevor Hines [ 30-Nov-16 ]

Our issues in TS seems to be around the site we are uploading to having too many tags. (Well over 1000). I found this CMIS Jira:
https://issues.apache.org/jira/browse/CMIS-974

Comment by John-Taylor Smith [X] (Inactive) [ 14-Dec-16 ]

Issue is still present with Activiti 1.5.2.1, Share Connector 1.5.2.1, and Alfresco 5.1.1.4.

Per the JIRA Trevor Hines linked, is it possible to switch the the browser binding?

Comment by Ben Kelley [ 08-May-17 ]

Issue still present with APS v1.6, ACS v5.2 and Share Connector 1.6

Note that this reproducible in APS by starting the OOTB "Review and Approve" workflow and selecting an image stores in ACS.

Comment by Marina Oliveira [ 03-Aug-20 ]

Project clean up - old ticket. If still relevant and applicable, please re-open it.

Generated at Tue May 18 06:43:26 BST 2021 using Jira 7.13.15#713015-sha1:7c5ddd2c3e1709974ae9c48c17df8edd3919fe2c.