[MNT-19867] QS template fails to create the APSStack when you select MySql because the version is hardcoded Created: 30-Jul-18  Updated: 02-Dec-19

Status: Open
Project: Service Packs and Hot Fixes
Component/s: APS Kickstart/Studio
Affects Version/s: Alfresco Process Services 1.9
Fix Version/s: Alfresco Process Services .N

Type: Bug
Reporter: Jennie Soria [X] (Inactive) Assignee: Mark Howarth
Resolution: Unresolved Votes: 0
Labels: None
Remaining Estimate: Not Specified
Time Spent: Not Specified
Original Estimate: Not Specified
Environment:

AWS APS QS 1.9


Attachments: PNG File errorstack1.png     PNG File templateDB1.png    
Bug Priority:
Category 2

 Description   

Summary

Linked to git issue:
https://github.com/aws-quickstart/quickstart-alfresco-process-services/issues/17

QS template fails to create the APSStack when you select MySql in the Ohio region because the version is hardcoded.

Looking at the stack failure it shows:

this is in the template:
https://github.com/aws-quickstart/quickstart-alfresco-process-services/blob/master/templates/aps.template

Expected Behavior

  • Version should be selectable on template for the Database type being used

Actual Behavior

  • Version is hardcoded and is not actually available

Additional Notes
The versions should not be hardcoded for DB versions.
In this case the template was used to startup stack in Ohio.

That version is not available in any region:
https://docs.aws.amazon.com/AmazonRDS/latest/UserGuide/CHAP_MySQL.html#MySQL.Concepts.VersionMgmt



 Comments   
Comment by Mark Howarth [ 23-Aug-19 ]

Reassigning to Doug Gruber, the new PM for APS.

Comment by Mark Howarth [ 02-Dec-19 ]

Assigning to Mark Howarth as PM for APS.

Generated at Mon Jul 13 10:06:45 BST 2020 using JIRA 7.6.3#76005-sha1:8a4e38d34af948780dbf52044e7aafb13a7cae58.