[MNT-19886] Need clarification on whether Solr4 is supported in ACS 6.0 and during upgrade Created: 01-Aug-18  Updated: 04-Oct-18  Resolved: 04-Oct-18

Status: Closed
Project: Service Packs and Hot Fixes
Component/s: Search and Indexing (non-UI), Upgrades
Affects Version/s: 6.0
Fix Version/s: None

Type: Documentation
Reporter: Seng Liaw Assignee: Closed Issues
Resolution: Resolved Votes: 0
Labels: None
Remaining Estimate: Not Specified
Time Spent: Not Specified
Original Estimate: Not Specified

Issue Links:
Dependency
Related
Bug Priority:
Category 2
Sprint: Search & Insight 1 - Roy Batty

 Description   

So we have some contradicting info in our ACS 6.0 doc now, which is creating confusion.

In the ACS 6.0 upgrade paths doc: - https://docs.alfresco.com/6.0/concepts/upgrade-path.html, it is written as:

You must upgrade to Alfresco Search Services 1.1.1 before upgrading the repository to 6.0. See Upgrading Search Services for more information.

In Migrate Solr4 to Solr6 doc: - https://docs.alfresco.com/6.0/tasks/solr4-solr6-migration.html, it said differently

step1: Upgrade to Alfresco Content Services 6.0 and continue to use the Solr 4 search service as before.

In this doc, we said you can continue to use Solr4 (although without any clear steps provided on how to configure ACS 6.0 with Solr4, and the fact is that we also do not deliver any Solr4 installation package in ACS 6.0 distriibution zip or in release note, and we only support Tomcat 8 with ACS 6.0 and Solr4 only QA tested and supported in Tomcat 7 as per 5.2.x).

So exactly which documentation has the correct info ?

Can someone please confirm whether customer may upgrade to ACS 6.0 and still use Solr4? If yes, how can they configure ACS 6.0 to use Solr4 ?

Bottomline: we should ensure all documentation page deliver the same message to avoid customer confusion.


Generated at Sun Mar 07 00:28:34 GMT 2021 using Jira 7.13.15#713015-sha1:7c5ddd2c3e1709974ae9c48c17df8edd3919fe2c.